PHPバージョン切替機能提供開始のお知らせ

本日より、ADAMコントロールパネルでPHPのバージョン切り替えが可能になりました。選択できるバージョンは 5.2/5.3/5.5 です。PHP5.3以降では動作仕様が変更されますので、バージョンの切り替えをする場合は、お客様にて事前に準備をしていただく必要があります。

バージョン切替のしかた

ADAMコントロールパネルにログインし「PHPバージョン切替」から切り替えてください。本日までにご利用中のアカウントは5.2が選択されています。

PHP5.2と5.3以降の仕様の違い

PHP5.2はApacheモジュール版で動作していますが、5.3以降はCGI版でのご提供となります。

バージョン切替前の準備

PHP5.3以降の仕様変更に伴い、下記の4点について確認・修正をしていただく必要があります。

  • MySQLパスワードの再設定
  • ファイルの所有者の修正
  • ファイルのパーミッションの修正
  • 設定ファイルの移行