PHP5.5の提供終了とPHP5.6への切り替えについて

いつもADAMレンタルウェブをご利用くださりありがとうございます。

先日ご案内いたしました通り、下記の日程でPHP5.5の提供を終了いたします。

提供終了日
2018年8月31日(金)

現在、PHP5.5をご利用中のお客様は、PHP5.6以上へバージョンの切り替えをして、プログラムの動作確認をされることを強く推奨いたします。PHPのバージョン切り替えはADAM管理パネルから行うことができます。

提供終了時にPHP5.5をご利用のアカウントにつきましては、弊社がPHP5.6への切り替えを行いますので、あらかじめご了承ください。

PHP5.6以上で発生する文字化けについて

PHP5.5からPHP5.6以上にバージョンの切り替えをした時に、文字化けが発生する場合があることを確認しております。これはPHP5.6から、設定ディレクティブ default_charset の初期値が UTF-8 に変更されたことによるものです。この設定により、HTTPヘッダに Content-Type: "text/html; charset=UTF-8" が追加されるため、コンテンツの文字エンコーディングが UTF-8 以外の場合に文字化けが発生します。

この問題を回避するには .user.ini ファイルを使用してPHPの設定を変更します。